TAW App

Minor incident Mobile App
2019-03-01 15:02 GMT · 20 minutes

Updates

Resolved

In Development.

March 1, 2019 · 15:23 GMT
Monitoring

TAW Mobile App is in development, we expect an a release date between April - May. The TAW App will be available on both iOS, and Android.

March 1, 2019 · 15:02 GMT

← Back